28 de agosto de 2012

Adobe Flash Builder 4.7 :D

Hola a todos, me contenté bastante al leer una noticia ojeando el twitter antes de quedarme dormido y pues aquí se las traigo en español. Me pareció haber visto algo que decía Flash Builder 4.7 is out, pensé que era broma para ser sincero.. entro al blog de oficial del equipo de Flex de Adobe, y… era cierto Adobe Flash Builder 4.7 existe, y publicada hace 3 horas.

Las características que trae esta nueva versión son las siguientes

  • Soporte para Apache Flex 4.8, Flash Player 11 y Adobe AIR 3.4
  • Concurrencia en Actionscript
  • Soporte para despliegue, pruebas y depuración de dispositivos iOS vía USB
  • Soporte para simulador de iOS
  • Configuración de múltiples build targets para proyectos multi-pantallas
  • Un compilado más rápido de próxima generación de ActionScript
  • Mejoras en la organización de Imports
    • Agregar imports faltantes
    • Consolidación de imports a nivel de paquetes
  • Un nuevas funciones de asistencia
    • Asignar parámetros a un campo nuevo o existente
    • Convertir una variable local a parámetro
    • Crear nueva variable local con casteo de tipo
    • Convertir funciones anónimas en funciones con nombre
    • Reemplazo de sentencias condicionales con if-else
  • Resaltado de errores en tiempo real usando el nuevo compilador de ActionScript.
  • Y continúa el soporte para las versiones del SDK de Flex 4.6.23201, AIR 3.1.0.4880 y Flash Player 11.1.102.55
  • ahhhhh y está para máquinas de 64 bits Open-mouthed smile

iOS debug

Requerimientos mínimos (Esto si se los dejo en inglés)

  • 2 GHz or a faster processor
  • Microsoft® Windows® XP with Service Pack 3, Windows® 7 (32-bit or 64-bit), Windows 8 Release Preview (64-bit)
  • 1 GB of RAM (2 GB recommended)
  • 5 GB of available hard-disk space
  • For Windows 32-bit: Java™ Virtual Machine (32-bit): IBM® JRE 1.6 or Sun™ JRE 1.6
  • For Windows 64-bit: Java™ Virtual Machine (64-bit): IBM® JRE 1.6 or Sun™ JRE 1.6
  • 1024x768 display (1280x800 recommended) with 16-bit video card
  • *Eclipse™ 3.7 or Eclipse™ 4.2 (for plug-in installation)

 

P.D.

Se puede instalar FB4.7 sin necesidad de desinstalar 4.6.

Para más detalle de las nuevas características pueden verlo aquí

Y, para descargarlo, hasta ahora va en 6% por que pesa nada mas y nada menos que 1 GB, se pueden ir a Adobe Labs.

Saludos, XD